Teiid 12.2.1 Released

< Back

Teiid 12.2.1 is now available for download and addresses several important issues.

Teiid 12.2.1 addresses 8 issues:

  • [TEIID-5742] - Info log on each unauthenticated action
  • [TEIID-5749] - CVE's requiring upgrade libthrift to 0.12.0
  • [TEIID-5758] - CVE CVE-2019-0201 - Zookeeper
  • [TEIID-5764] - Refine OpenApi 3.0 Support for OData
  • [TEIID-5744] - Teiid pg does not handle empty prepared sql
  • [TEIID-5748] - Cassandra issue with table names containing upper case characters
  • [TEIID-5754] - Schema visibility issues
  • [TEIID-5765] - Criteria Pushdown is not working on FULL OUTER JOIN

12.1.2 will be available in approximately 6 weeks. 12.2.2 will be available in approximately 8 weeks. Both will contain only critical/blocker issues.

Teiid 12.3.0 will be available in 4-5 weeks and will contain features such as WildFly 17 support, JSONTABLE, and support for OpenAPI v3 sources.

Thank you, Steve