Teiid Wildfly Downloads


Runtime


Latest

Previous

Unstable

Historical Version Downloads - 10.x (WildFly 11.0.0 Java 8+) - 9.x (WildFly 10.0.0 Java 8+) - 9.0 (WildFly 9.0.2 Java 7+) - 8.13 (WildFly 9.0.2 Java 7+) - 8.12 (EAP 6.4 Alpha Java 6+) - 8.11 and prior


IMPORTANT NOTE: Teiid is targeted to specific platforms. See more below.

Maven

You may also directly reference the Teiid artifacts from the download table above from the Maven Central Repository.

Note: Releases prior to 10.0 should use the JBoss Public Maven Repository - http://repository.jboss.org/nexus/content/groups/public/ and the org.jboss.teiid group instead.

Note: Releases prior to 10.1 use the -Final suffix for the initial release 10.0.0-Final, 9.3.0-Final, etc.

JDBC Driver

<dependency>
  <groupId>org.teiid</groupId>
  <artifactId>teiid</artifactId>
  <classifier>jdbc</classifier>
  <version>X.X.X</version>
</dependency>

Server Distribution

<dependency>
  <groupId>org.teiid</groupId>
  <artifactId>teiid</artifactId>
  <classifier>wildfly-server</classifier>
  <version>X.X.X</version>
  <type>zip</type>
</dependency>

Embedding

You should use maven to directly control what features you need when embedding Teiid. See:


Docker

Docker images of the combined WildFly/Teiid/Console runtime are available at Docker Hub. These are base images from which you may layer in your modules and deployments.


Installation

Please consult the respective Migration Guides from 8.x to 9.x and from 9.x to 10.x.

Teiid Requires:

  • JRE
    • Java 1.8 for Teiid 9.1+
  • WildFly
    • WildFly 11.0.0 for Teiid 10.0.0+
    • WildFly 11.0.0.CR1 for Teiid 10.0.0.Beta2+
    • WildFly 10.0.0 for Teiid 9.1 - 10.0.0.Beta1

For complete installation instructions please refer to “Administrator’s Guide” in Teiid Documents section.

For Quick “standalone” mode installation of the latest Teiid

Either start by unzip the kit above that includes EAP or:

  1. Install the appropriate WildFly / EAP version (see above).
  2. UnZip Teiid archive over the installed application server

Then start the server using “standalone.sh -c standalone-teiid.xml” command.

Additionally you’ll need to supply any third-party jars needed to connect to your enterprise sources like JDBC Drivers.

Teiid JDBC Driver teiid-<version>-jdbc.jar can be downloaded from above links for accessing a VDB through JDBC.

Follow the quick start and the Teiid Designer documentation to understand how to create a VDB. Use and contribute to the Teiid community for additional examples and configuration options for Teiid.


Tooling


Teiid Designer

Teiid Designer is optional Eclipse based tooling for creation of VDBs in a modeling environment. Note that Teiid Designer currently works with only Teiid 9.0 and earlier. However VDBs developed against a Teiid 9.0 environment will still be valid for deployment into later releases.

Latest Release 11.1.3 Final - May 18th, 2018


Stable 11.x Releases


Install into RH Developer Studio 11.x

Install into Eclipse 4.7 (Oxygen)


Install into RH Developer Studio 10.1

Install into Eclipse 4.6 (Neon)